Erfahrungsbericht mit "Open Source Laptop" von Dell

Meine liebe Frau ist seit gestern stolze Besitzerin eines Laptops. Und mir wurde das große Vergnügen zu Teil, das Gerät auszuwählen und für die Benutzung durch meine Frau vorzubereiten.
Da Dell ja inzwischen PCs und Laptops mit vorinstalliertem Ubuntu, der GNU/Linux – Distribution, die ich seit 2004 verwende vertreibt (und zu der ich meine Frau auch Anfang letzten Jahres bekehrt habe), war Dell meine erste Anlaufstelle. Ein wenig Preise verglichen, zufriedengestellt (wirkt sich tatsächlich auch preislich aus, das Betriebsystem nicht bezahlen zu müssen…) und bestellt.
Es handelt sich um einen Inspiron 6400n, Ubuntu 7.04 “Feisty Fawn” war vorinstalliert. Das ist zwar nicht die ganz aktuelle Version (seit Mitte Oktober gibt es 7.10 “Gutsy Gibon”), aber aktuell genug. Da es gleich um WLAN gehen wird, der Informationshalber noch den Onboard WLAN-Adapter: “Intel Pro Wireless 3945 (for Celeron Processor)”. Das System bootete ohne Mucken und startete mit dem obligatorischen ersten Login nach der Neuinstallation. Sprache, Zeitzone, Tastaturbelegung festgelegt – fertig.
Nun ging es natürlich ans eingemachte: Ans Netz mit der Kiste – und zwar über WLAN und WPA2-verschlüsselt!
Das flutscht auch so einfach wie Eis essen (muss ich übrigens auch bald mal wieder machen). Oben rechts wartet bereits das Network-Manager-Applet darauf, dass man ihm sagt, in welches Netz eingewählt werden soll.

Network-Manager-Applet

Eigenes Netz ausgewählt (ja, mein Netz heißt Valinor…), Verschlüsselung festgelegt, Schlüssel eingegeben – fertig. Verbindung wird direkt hergestellt. Der Network-Manager scheint es übrigens nicht zu mögen, wenn die SSID des versteckt ist. Lässt sich bestimmt hinfrickeln. Aber da eine versteckte SSID eh keine adäquate Sicherheitsmaßnahme darstellt, hab ich die einfach sichtbar gelassen.

Als die Netzverbindung dann stand, habe ich das System auf “Gutsy” geupgradet, lief reibungslos. Sogar die Multimedia-Tasten funktionierten out-of-the-box.

Die einzige Sache, die Wünsche offenließ, war die Bildschirmauflösung. Der Laptop hat ein Widescreen-Display, wird jedoch mit einer Bildschirmauflösung von 1024×768 (also für 4 zu 3) betrieben. Daher wirkt alles etwas gestaucht. Dies ließ sich bei mir jedoch durch die Installation eines einzigen Pakets beheben: 915resolution. Nachdem ich dieses per sudo apt-get install 915resolution installiert hatte (geht natürlich auch über Synaptic), war nach einem Neustart des X-Servers (Strg-Alt-Backspace) alles fein (Auflösung 1280×800).

P.S.: Ich alter Möchtegern-GNU/Linux-Wizard habe es natürlich geschafft, aus einfach kompliziert zu machen. Der erste Versuch mit dem Network-Manager war nicht erfolgreich, weil in meinem WLAN-Router der MAC-Filter noch aktiv. Der Router akzeptierte also keine Verbindungen von neuen Geräten. Ich hatte das in dem Moment nicht auf dem Zeiger und begann wie ein Wilder mit den Interfaces und wpa_supplicant.conf u.ä. rumzufrickeln. Erst als das alles auch nicht zum Erfolg führte, fiel mir siedendheiß der MAC-Filter ein. Als ich den MAC-Filter entfernt und alles Gefrickel wieder rückgängig gemacht hatte, funktionierte dann alles wie oben beschrieben über den Network-Manager.

Kommentar verfassen